FANDOM


Forums: Index > Help desk > How to add a new nation ?

Hi there,


So I thought it would be fun to add a new nation. Some googling took me to http://freeciv.wikia.com/wiki/Nations

I created my ruleset. OK. Now, it's not clear at all where to go from here.

I'm on Ubuntu, got the game (and updates) via Synaptic, and I don't intent to recompile the package, hence my hesitation to edit Makefile.am

Could someone point me toward a procedure to make my ruleset effective ?


Thanks

The Nations page is currently somewhat aimed at people adding nations to the source code, I agree.
Here's a procedure that might work in your situation. Let us know how you get on.
Put your nation file for 'elbonia' in ~/.freeciv/2.3/nation/elbonia.ruleset (creating the intermediate directories as necessary) (assuming you're using Freeciv 2.3.x; adjust as appropriate for other versions).
If you have flags, put them in 2.3/flags similarly.
Take a copy of the nation list /usr/share/games/freeciv/default/nations.ruleset, put it in ~/.freeciv/2.3/default/nations.ruleset, and edit it to add elbonia.ruleset.
This copy of the nation list overrides the installed one, so if you upgrade your Freeciv package from 2.3.x to 2.3.y and that changes the system nation.ruleset, you won't benefit from the change. (Which is a bit icky, but nation.ruleset is unlikely to change in a minor release.)
Because we've put the file in ~/.freeciv/2.3/, however, it will not override the 2.4 nations if you upgrade to 2.4.x (once that's eventually released and makes it into Ubuntu).
-- JTN (talk) 00:09, December 5, 2012 (UTC)
OK, many months later, and I'm back at it. Thank you for your detailed explanation. I followed it to the letter, but then I couldn't even launch Freeciv at all. Whatever the option (Start New Game, Load Saved Game ...) it would hang with the status bar saying "Lost connection to server (read error)!"
I goggled that but found nothing relevant. I had never thought of lauching the server, so I tryied but nothing happened but the quick flash of a console.
So the server errors out upon seeing your new nation. You're on the right track to debug this by running server separately - client won't show error messages from the server it runs internally. I assume you tried to run server from some icon or from menu which made temporary console to open for server to run, and which then immediately closed when server crashed. You should run server from persistent console instead, i.e., from one which you have opened yourself. That's program called xterm, kterm, maybe just terminal, or something similar (depends on your ubuntu installation). Run freeciv server on that terminal by typing "freeciv-server" and execution will just return to that terminal when freeciv server crashes, leaving freeciv server output there. --Cazfi (talk) 10:42, February 27, 2013 (UTC)
After reversing the customizations, the "client"(?) launched as usual, and the server shows a nice startup and waits at a prompt. I browsed the help for freeciv-server, glanced at the manpage and knew I wouldn't go further.
Will you help poor Elbonia find its due rank among the Nations ?
88.172.186.106 21:58, February 26, 2013 (UTC)
Server dying indicates a syntax error in the nation ruleset (if you don't use your own flag, which could also cause errors.) Suggestion, grab Nations/native as described on Nations, and use it for experiments in a modified nations.ruleset. –82.113.121.17 21:01, March 2, 2013 (UTC)
Old story, fresh attempt. Thanks to above help, I now have a playable Elbonia, yeah. I even made flags. Which don't load, that's the rub. I tried to put them in ~/.freeciv/2.3/flags as well as in /usr/share/games/freeciv/flags but all I get is what I suppose is the default flag : baby blue field with three question marks. Just one step away from flying colors, help ?
88.172.186.106 17:21, May 14, 2013 (UTC)
Have you modified your client side tileset (separate from server side ruleset) to include the flag? For example amplio2.tilespec lists in its files misc/flags-large.spec and misc/shields-large.spec which in turn should list your flag sprites. --Cazfi (talk) 22:14, May 14, 2013 (UTC)
No I haven't. Scrutinizing this Wikia I edited flags.spec and the like. Elbonian flag now in city bar, but not on units shields. I'll try editing the tile set as you say, but shall I edit the .spec files in place or first copy them in ~/.freeciv/2.3/ ? I'll try on a userland copy first. I don't even know what tileset I'm using, I'll try amplio2 first, assuming it's the default.
88.172.186.106 05:41, May 15, 2013 (UTC)
I found some hint that I may actually be using amplio2, still unsure.
Anyway, I now have in userland :
- an edited copy of nations.ruleset
- elbonian.ruleset
- an unedited copy of amplio2.tileset
- a copy of the whole Amplio2 directory
- edited copies of misc/(flags|shields)(-large).spec
- a copy of the flags directoy in which I added custom elbonia(-shield)(-large).png files.
Still no unit shields :'-( , either with the stand alone client or launching the server first.
I made the flag by editing some other nation's with The Gimp. Maybe there is a problem here : the wiki is not that clear whether the flags should be SVG or PNG, or maybe there is something I don't get about the PNG file format.
88.172.186.106 11:41, May 15, 2013 (UTC)
Success and closure, at last !
I re-made the png files, by editing another nation's with the Gimp again. This time it works, go figure.
Now, it's finally Elbonia against The Rest of The World, wish me luck ;-)
88.172.186.106 15:52, May 15, 2013 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.

Fandom may earn an affiliate commission on sales made from links on this page.

Stream the best stories.

Fandom may earn an affiliate commission on sales made from links on this page.

Get Disney+