Freeciv
Advertisement

Would it be possible to have some explanation of installing mods (specifically ancients for version 2.2) for idiots? I don't get it. Assume minimal computer savvy. Thanks.

Forums: Index > Playing Freeciv > Mods for idiots



Advertisement