FANDOM


(Created page with "This document describes how to convert freeciv 2.6 compatible soundset to development version (one that will become freeciv 3.0) compatible ones. Currently this goes up to com...")
 
(Mark to be on alpha1 level)
Line 1: Line 1:
This document describes how to convert freeciv 2.6 compatible soundset to development version (one that will become freeciv 3.0) compatible ones. Currently this goes up to compatibility with freeciv S3_0 commit 85d3beedee 14-Mar-18.
+
This document describes how to convert freeciv 2.6 compatible soundset to development version (one that will become freeciv 3.0) compatible ones. Currently this goes up to compatibility with freeciv S3_0 commit f0bb6c56d0 (alpha1) 16-Mar-18.
   
 
==Capability==
 
==Capability==

Revision as of 01:38, March 16, 2018

This document describes how to convert freeciv 2.6 compatible soundset to development version (one that will become freeciv 3.0) compatible ones. Currently this goes up to compatibility with freeciv S3_0 commit f0bb6c56d0 (alpha1) 16-Mar-18.

Capability

Capability string of soundspec file must be changed.

[soundspec]
options = "+Freeciv-soundset-Devel-2018-02-27"

Event tag rename

Event tag e_unit_win is renamed to e_unit_win_def. Update reference to it in the soundspec.

Community content is available under CC-BY-SA unless otherwise noted.